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3K, DR BRSERRE A e HEHERT | S TR AR RE S A SCRY IR 2 WA B BT AF .. &R
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SRR “DS” 4% . &GS HIER IR NS Z AT, DS 5K BAEN
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RTRITRTEMBFEE, 5% MPLAB® IDE 764:#58). M Help (3EBh) ik
Topics (FE/) , ITHIAFELHE AR,

fa I
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AT L H LA SO 205
CREY 5
P18 R 7~
Arial F4%:
RUATRE ZH MPLAB® IDE User’s Guide
FoR IR ...Iis the only compiler...
EESSYNG [} the Output window
St HE the Settings dialog
SR PALE I select Enable Programmer
55 % B EHEF 1 E B4 “Save project before build”
;ﬂ%\%ﬁ%%%%ﬂ%i KT File>Save
FAATRF ] HE L Click OK
IR Click the Power tab
‘bnnnn TR 0 G H A ‘b00100, ‘b10
PG T <> PRSCAK A 1k Press <Enter>, <F1>
Courier Fk:
3@ Courier JEACHL 4] #define START
A4 autoexec.bat
S AR c:\mccl8\h
S _asm, _endasm, static
A AT -Opa+, -Opa-
(OAIEN 0, 1
244 Courier S H file.o, where file canbe
any valid filename
0xnnnn 16 JEHIEL  nfE—A> 16 #E4 | OxFFFFE, 0x007A
A
R[] kS mccl8 [options] file
[options]
RIGFRIEL ]} WIEME RS, “o” B |errorlevel {0]1}
Liss
BET .. B E G 1SR var_name [,

var_name...]

AR PR AL

void main (void)
{
}
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microchip SCRYE CHRAE, HEFEAE B0 5% kL.
README 31t

KT Microchip L EMEHE R, & EEHAAH W1 README X (ASCII 3CA S
% .

MPLAB® ASM30, MPLAB LINK30 and Utilities User's Guide (DS51317)

$5 518 | dsPIC DSC I 4i%%. MPLAB ASM30. dsPIC DSC ##:%¢. MPLAB LINK30
& F dsPIC DSC sz HFEF, £u3E MPLAB LIB30 fER4FE S / PR BEFLT o

MPLAB® C30 C 4ii%3/fl /" f5% (DS51284C_CN)

dsPIC DSC C %ii¥2318% . MPLAB LINK30 S5iXA T HEABd & H .

dsPIC® Language Tools Libraries (DS51456)

DSP. dsPIC 4MgcfibrifE (BLFEH) FE, LA MPLAB C30 A k%L, & dsPIC i&
HLA—EMEH.

GNU HTML 314

T TRKDCE AR HOX A . B TARME GNU JFA TR, MPLAB C30 #l
J& LI A LR )

dsPIC30F Data Sheet General Purpose and Sensor Families (DS70083)

X dsPIC30F 75 544y (DSC) T M. BAENA TR LI 4E
Ko VRN TAFE SRR B DSP #AEFISME Dhfe . b A FE S S5
dsPIC30F R%I2%F/ft (DS70046C_CN)

ZRINSHNSHEIEE. M9 T dsPIC30F MCU 41 1) B2 k) Fl A At

dsPIC30F Programmer’s Reference Manual (DS70030)

dsPIC30F 57 g ds (S %451 . Bdmg BB R 45 &2k .

C iR B

American National Standard for Information Systems — Programming Language — C.
American National Standards Institute (ANSI), 11 West 42nd. Street, New York,
New York, 10036.

BEARERLE T C B 5 g SRR 3K, JExE C R bAT T ke JLH 23w
C FEPAEZ M LR S LI R PTSetE, i e R AT s .
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MPLINK™ #1 MPLAB LINK30 H briE#ds; LLJ& MPLIB™ F1I MPLAB LIB30 H #x
[ PR

« fiE#8—Microchip 7E 2k {/i HL.2% 1 5085 B . 55 MPLAB ICE2000 Al MPLAB
ICE4000.

o ZEL YRR —Microchip £k # MPLAB ICD 2 [ #if5 S -

- MPLAB IDE—Microchip MPLAB IDE, I JF% %% T2 1) Windows® 4 % I & 1
B s B, FE4E T MPLAB IDE. MPLAB SIM #4454 #%. MPLAB IDE
T0H 5 HE A DA R 0 g RO R T
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1 F REHE

11 &

A fE MPLAB T KR8 (IDE) V6.30 ¢ 5 5B 1A Th 4 ] MPLAB C30 f1)
BAL ST W 223 dsPIC30F 2t T.F.. MPLAB IDE 4454 2235 4E PC
L

TEFA R HE e i MPLAB IDE ##F, i n] L4 2% AN www.microchip.com FF
#;. MPLAB IDE %5 H 4 H4F1 MPLAB SIM #4588, DG EA TSR s
A FH 20 FE P R R o

AEEBHE LR N2

« 2% MPLAB ASM30. MPLAB LINK30 filiE 5 T Bz iR P

« 23 MPLAB C30

« 1% MPLAB C30

o HFENEIA

1.2 %23 MPLAB ASM30. MPLAB LINK30 fliE = TASHEF

b MPLAB IDE % 2 42{it MPLAB ASM30 FI MPLAB LINK30. 7 MPLAB C30 % i¥#%
f2edE 4 7 MPLAB ASM30 fi1 MPLAB LINK30. 4 T#iEfT# dsPIC30F T B
Z A, RN Z%AE H B MPLAB C30 4t g2 # I (13 46 T B IR A

1.3 %% MPLAB C30
o 725 MPLAB C30 % PF 2% (1 THRAS I, W g2 56 PCHL_EBUAT I ST o A Z5i%}
AT e A ) SO AT A5 10
o BRI AT 23 MPLAB C30vX.XX (XXX J& 4R IRA S ) k. %
W LA R A 1 — RATEHE PR BT 2285 . R dEid FE vl RE A28 LB 1
I A] 48 Z2 1S H L ) MPLAB IDE FHEL AR AR G IS4
o JEHASREE T RIRBIKRE 2], itk EXAMPLES i & EHERE T .

1.4 H#Z MPLAB C30
FT I o 3 2% 22 S 35 3 UNWISE.EXE X ff.

W I MPLAB C30 HTHRIRAS IR IR A 22 e . i b e fm s In 3]
SR P R SO AN 2 BB o
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1.5  FHEMR

I AR B R B TR AR C w5 LA ACRI ] MPLAB 4R T & 5% (IDED
FIMPLAB C30 %t 2% AR TT R R ARG RIS o A STRIA 44T o] Q1 2 70 G 196 15
H, Wi FH dsPIC30F &5 v [ Dhedn 5 A0, DL Wl 36 A A - MPLAB C30
%5 R ARH
T 5EE 224 MPLAB C30 4w vE28 A1 MPLAB IDE v6.30 (EREEHThEAS) o W5 &R T
dsPIC® [fj3ciik, 41 dsPIC30F Data Sheet General Purpose and Sensor Families
(DS70083) #1 dsPIC30F Programmer’s Reference Manual (DS70030) , LL{f3k75
KT R PEZRIGE B, WRR IR 74 IR AP NZ .,
XTI Tl ] MPLAB C30 4 i3 2% 1 20FE A 45 -
* % 2 %ﬁ?@?ﬂﬂﬁ[

- OUEE A I H

- FEREIARAS B AT PP T R TR T A

- PR .
o BIENATWM:

- A Bk G g U S

- A{E C g S ke
* % 4 E"ﬁé’&?ﬁﬂﬁ

- f£ MPLAB C30 % i¢4% il V4415 5 DSP 127

- HilgaE SR L1624
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F2E HAE1—QENH

A HRE T T 2 YR AR D L ) MPLAB IDE v6.xx 35 H T i (). & 4448 H MPLAB SIM
B KA dsPIC30F6014 5 F e AFFE B H3% C:\pic30 tools K
MPLAB C30 4 s 1 2¢3% H 3 o ANEFEALHE

o BIESCAE

o AT H S

o {EHIH %

o W Y PRIETT

s HuiFIiH

o Y PRI

* ffiH MPLAB SIM #4540 8% 34T 178

o AR R S A

o I GaARAS 1 1R

o RAZE2]

2.2 BIEIUH

JA5)) MPLAB IDE v6.30 (=SB UhRAS) ik +% File>New T TN ¥ F1 A SC
fEo B 24 45 T RN (B WRAE B 7 3OS, 95 DURTREIG 21D il SC o 11
RIRACHS o

B 2-1: MYFILE.C
#include "p30£6014.h"

int counter; // for TRISB and PORTB declarations
int main (void)

{

counter = 1;
TRISB = 0; // configure PORTB for output
while (1) // do forever

{
PORTB = counter; // send value of ‘counter’ out PORTB
counter++;

}

return 0;

}

TRISB M PORTB & dsPIC30F6014 it [I4F ik L it 27 745 - PORTB /& — 4118 H 4 A /5
HE|H. TRISB AT SRALE PORTB 5IHIAMA (1) sidiE (0).

{filH] File>Save As ¥ X Ji 4710 4 H 3k M) \examples H3X T GHT N
C:\pic30 tools\examples), M4 K MyFile.c.
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23 fEHTENS

&F% Project>Project Wizard K65 H o G HIL— DY T TH . s Next> 4k4EL,

1.

7F “Step One: Select a Device” 1, il FHigik$e dsPIC30F6014 it 1,
s Next> 4k4k,

7t “Step Two: Select a language toolsuite” ', # “Microchip C30
Toolsuite” {24 “Active Toolsuite” . #XJ5 i T HAT (FF “Toolsuite
Contents” 2 F) WRANE T LHIFR & e B -5 HAR I v AT ST % A1
(K 2-1 .

MPLAB ASM30 JI_ i #5451 “LOCATION” " (i1 4 F2 ¥ il 04T 3 #F
pic30-as.exe. WIHREAH XA, NN R 0] PAT AL S, W
NE

C:\Program Files\MPLAB IDE\dsPIC Tools\Bin\pic30-as.exe

MPLAB C30 4 ¥ #e v f511 “LOCATION” N {4 i f 5 ol $h A7 30 1F
pic30-gcc.exeo QSRR IXA A, NN BN N R AT AT SO,
it V. F

C:\pic30 tools\bin\pic30-gcc.exe

MPLAB LINK30 H brgEfzaemifi1n “LOCATION” R FIBEE R ol $h AT 30 1F
pic30-1d.exe. WIAREA XA, NN R W PAT AFRIALE, @
it V. F

C:\Program Files\MPLAB IDE\dsPIC Tools\Bin\pic30-1ld.exe

& Next> 4k4:.

& 2-1: WHMAS — EFES TH

Project Wizard

Step Two: r‘h
Select a language toolzuite

Active Toolsuite: IMicrochip C30 Toalsuite j

i~ Toolsuite Contents

MPLAB pler (pical-gec.
MPLAE LIMK.30 Object Linker [pic30-d.exe]

i~ Location

C:\Frogram Files\MPLAR IDENDzPIC T ools\Bin'pic30-as. exe Browse... |

Helpl My Suite lsn't Listed! |

[ Show all installed toolsuites

< Back I Mext » I Cancel | Help

DS70094C_CN 3 10 7T
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3. {f “Step Three: Name your project” "', BEATIH % MyProject I Al
BROWSE i A MPLAB C30 %3¢ H 3% T \examples . AR5 Ml
NEXT > 4k48

K 2-2:

Wi H [T — T E A H R

Project Wizard

Step Three:

Mame your project

x|

r~ Project Mame

IM yProject

r~ Project Directory

IE:\picBD_tooIs\examples

Browse... I

< Back |

Mext » | Cancel | Help

4. fF “Step Four: Add any existing files to your project” 1, s g4 43

TH

G, WEHEIGHIAE \examples UMK AP AR SCAF MyFile. co miih
ADD>> ¥R I 2130 H 2GS fE a3 rh - GREMEATLD o

& 2-3:

WH 1% — % C YA+

Project Wizard

Step Four:

Add any existing files to your project

x|

2] examples

example].cmd
exampled.c
get_month.s
hello.c
hello.crd J
main. ¢
modulo.s

AyFile.c
output.cmd
output.s

un_example] ¥
3

;I Add |

Remove |

O C:hpic30_toolshexamplesiMyFile.o

1 |

Check the box to copy the file ta the
project directory

< Back I Mext » I Cancel Help

© 2005 Microchip Technology Inc.
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LR, WIS INBE R IR ST, A AN Ee 2 T dsPIC30F6014 ¥ 47-fifi 4 4 o
BEREAEIA SO T MPLAB C30 2235 H 3k N \support\gld ¥, [~
#F) p30£6014.g1d M, HErpe It Adi ADD>> B e g i Im H .

2-4: W H [T — SRS A

Project Wizard

Step Four:
Add any existing files to your project

x|

""" p30fE01 U-;I O C:pica0_toolshexamples\MyFile. o

----- P00 _l’i\‘dd>> O C:pic30_toolshsupportgldyp30E

----- p30fE011.

----- p30fE0N1£

..... p30fE012. ml

----- p30fE0N 2¢

----- p30fE01 3.

----- panteat 2

----- pa0fE0T 4.

----- p30fE0T 4¢

----- p30zim. gl LI—I _’I

{1 h * Check the box to copy the file ta the

LI—I L4 project directarny

< Back I Mest > I

Cancel Help

i Next> 4k4E,

7E Summary (2D &P EFGE “OiH S5, BiEd . TREaRmH
SCPFIAT BT IE A W RS — T, w] LA A Back dz [ F— NG HE
R Finish £ 055 B A TAEX .
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24 fFHBERED

T H % O 1E MPLAB IDE [F) TAEIX N o TAEX 1S40 8 R T0H 1 T00 P e A A
i, MyProject.mcw, MWiHXH# MyProject.mep YEAIHKTIES “T587,

& 2-5: WHEEDO
=Y

=] MyProject.mcp
=I- Saurce Files
My File,c
- Header Files
- Object Files
- Library Files
[=]- Linker Scripks
L. p30FE014.gld
- Other Files

¥E: W R AR, RTINSO A4 I3 N B sl ek BROPR A B 1 S R
o KiehrfE s “Source Files” 5% “Linker Scripts” b1 isf filbr A7 B
oK m) I00 H 8 D038 24 1 3 A
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25 WEHFEN

DA, JLT-E4n LU dsPIC30F T RKRGHFIIH T . (HE, 7 2k Al H A 1T Hd
BEEI

1.

¥t Project>Build Options F riili  “Project” T~

CHTEILTID RFTEAE .

HANT0H 1) Build Options

¥ General CHEHD ETi+. EARLFET, AFHERH “Include Path” 73N
2, ABXTR H SOR R B0 H T RETT BN N 42, “Library Path” 2A%00 &

MPLAB C30 3% H & M) \1ib H 3%,

& 2-6: G PRI TN TEAE

Build Options For Project “MyProject.mcp™

General | MPLAB ASMBDI MPLAB C30 | MPLAB LINK30|

Output Directory, $BINDIR]:

Intermediates Directory, $[TMPDIR]:

Azzembler Include Path, $lAINDIR]:

Include Path, HIMCDIR]:

Library Path, $ILIBDIR):

| C:Apic30_toolshib

Linker-Script Path, $ILKRDIR]:

Help | Suite Defaultsl

E

x|

Browse...

Browse...

Browse...

Browse...

Browse...

NNy

Browse,..

QK I Cancel | Apply

DS70094C_CN 3 14 71
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TEfFE TR AR I-R o a] DONHR i 2] dsPIC TR [y 47T E D71 .

3. Miii MPLAB C30 &% ~. MPLAB C30 5 =AMEIi%f iFHE: General. Memory
Model (fFfiE#i%AL) F1 Optimizations (HEAL) o IX = ASEEIFAHEHE AJ 78
“Categories” "N SE,  H LA TEAE AR YA R AR Y A A s

R T, J5REF MPLAB C30 Bk i fir & fF I TR S

&l 2-7:

HIF SRR IE T — GENERAL

Build Options For Project “MyProject.mcp™

General | MPLAB ASM30  MPLAB C30 | MPLAB LINK30|

Categaries: | General j

2|

i~ Generate Command Line

™ Additional warnings
[~ Shict ANSI warnings

V¥ Generate debugging information
™ Support all AMSI-standard programs

™ Make warrings into erors

Macro Definitions

Add... |
Remove |
Remave Al |

I Inkerit global settings

Restore Defaults |

E

I Use Altemnate Settings

[a

QK I Cancel Apply

© 2005 Microchip Technology Inc.
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4. £ MPLAB LINK30 i£J5i+. MPLAB LINK30 5 =/NETUGHEHE: General.
Diagnostics (i) 1 Symbols & Output (55 A% H) o X = AR iFHE
n[#E “Categories” FH =g ik £, AT URHE - 1 P 28tk AH B R A

az,
HTIBATARTE R G AL 3, FHEA General B E M. HER/PNEE N
512,

K 2-8: B R E%EI — GENERAL

Build Options For Project "MyProject.mcp™ i 2=l

General | MPLAB ASM30 | MPLAB C30 MPLAB LINK3D |

Categories: I General j

Generate Command Line
[J\E Heap size: 514 bytes [~ &llow overlapped sections
|

Min Stack Size: I bytes I Link for ICD2

Symbal Definitions

Add... |
Remove |
Remave Al |

| It glabal settings Restore Defaults |

I--heap=51 2 -0"$[TARGETBASE).cof

I Use Altemnate Settings

I-o"$[TAHGETBASE].cof"

QK I Cancel Apply

DS70094C_CN % 16 11 © 2005 Microchip Technology Inc.
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5. %E$& MPLAB ASM30 itTi£. MPLAB ASM30 AL wiHE: General fll
Diagnostics. IXPANMEIU IEHER /£ “Categories” FHriik$e, HINLE
o AE PP P 2K A N A AR

FEXAI 7o, K RHFE MPLAB ASM30 RIA 1y SATIE AL o

&l 2-9:

YC g 28 4 PRI — GENERAL

Build Options For Project “MyProject.mcp™

General MPLAB ASM30 | MPLAB 30| MPLAB LINK30|

Categories: I General j

2|

i~ Generate Command Line
[~ Allow CALL optimization
™ Keep local symbols

V¥ Generate debugging information

Macro Definitions

Add... |
N
Remave Al |

Remove

I Inkerit global settings

Restore Defaults |

E

I Use Altemnate Settings

[a

()3 I Cancel

Apply

© 2005 Microchip Technology Inc.
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2.6 ‘miEWHE
¥ Project>Build All XI5 H MEAT 4 3 I GnRBERE . AT AT A AR el 24 1, 2
SR AERT L
ST ALK, Output CiiH) B FUAR R GRS 0 B, 1 o & I3 H

“BUILD SUCCEEDED” (ZwiRIh) M. WIRHERER, A AR SO N2 541
21 myfile.c XHMNEZT I

&l 2-10: %% Output & O

Build |Versi0n Contral | Find in Files |

Clean: Deleting intermediary and output files.

Clean: Dane.

Executing: "Chpic30_toolsibinypic3l-gec.exe" -D__dsPIC30FE0T4__-c-x ¢ "MyFile.c" -o"MyFile.o" -g
Executing: "Chpic30_toolsibinypic30-goc.exe" W, "Chpic30_tools\examplesiMyFile.o" —script="Cpic30_to
Executing: "CA\Program Files\MPLAE IDEVdsPIC_Tools\Binypicil-hin2hex exe" "MyProject.cof

writing MyProject hex

=ection PC addre=s byte addre=s length {w-pad) actual length {dec)

.reset 1] 1] 0=a O=6 (6}

. text 0=x100 =200 0x130 Oxze=d (228)
.dinit 0x198 0x330 0=10 Ozc (123
Livt Ox=d 0=a O=f8 Oxba (186}
Laivt Ox84 0x108 0=f8 Oxba (186}
.isr Oxlal 0=x340 Ox=d 0=x3 (3}
Total program memory used (bytes): Ox2ed {6213
Executing: "C\Program Files\MPLAB IDE\dsPIC_Tools\BinLeoff_iCoff.exe" "MyProject.cof

Loaded Chpic30_tools\examplesiMyProject cof

BUILD SUCCEEDED: Fri Jul 09 14:02:08 2004

1] | |

2.7 R IRSEERE
WRETR H 435 AR IR, AT B R AR A AT B N G 0% 5 (K AT
AT o 01 SR A8 A0 FE () 2 0817 PP (AR, I J 8 DL PR S5 2 D S AR IR T 4
FAES AR, 75 R BT, WL T MR S. EARBIT, W main () HHT
“int” @ XANLIER TR “47 . XK Output 7 1 rh HEAR 2 0 .

&l 2-11: HRIFER

— 1572
1 Finclude "p30f6014.h" | for TRISE and PORTE declarations TJ
2 )
3 int counter; |

4

= nt main ivoid)

5 i

7 counter = 1,

5 TRISE = 1=
Bl for &) | | Output EJ@
10

1 — m—
porTe|f| Buld | Yersion Contral | Findin Files|

=)

countel |Me|eting intermediary files... done.
¥ Executing: "CApic30_tools\bin\pic30-goc exe” -0__dsPIC30FE014__-c-x
return i1y ufile =:5: error: syntaz srror before "main’
Halting build on first failure as requested.
BUILD FAILED: YWed Dec 10 13:19:39 2003

mn opow

|
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X B Ourput & LIS =47 )5, I F B FROE H:
K 2-12: M HEAJEAHS

B C:\pic30_tools\examplesimyfile.c

R ——
1 #include "p30L£6014.h"™ /f for TRISE and PORTE declarations

int counter:

2
3
(4
5 . nt main (void) <:j
6 i
7
(=3

counter = 1;

TRISE = 0O: /¢ configure PORTE for output
=] while (1) /¢ do forewver
10 i
11 PORTE = counter; // send wvalue of 'counter' out PORTE
iz counter++;
13 '

return 0O; _ILI
3

Buld | Find in Files | MPLAB SIM30

Deleting intermediary files. .. done.

Ezecuting: "C:~PIC30_~1~bin“picil-gcc.exe" —-c —-x c "nyfile.c" —o
nyfile.c:5: parse error before "main"

Halting build on fir=st failure a= reguested.

BUILD FAILED

TR A L e PR B R, MR “nt” DLBASCAREIR, BIILIRE Y
VUM LA R BN “17 B “nt” SONIERIPOCHET “int”, XN XIAKAR
F2aAt, LR Project>Project Build All 3545 \E I e 45 5 .

© 2005 Microchip Technology Inc. DS70094C_CN 2 19 7T
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2.8

¥ F MPLAB SIM ZXA-HERI 28 54T R

FEPPANY A, 5 E R LR B . dEARZFR, BAMEH MPLAB SIM #:5
AR . FEIX MR 2% opr] DLEEYRARHD i B R o5, IR AT DLAE Watch  (LE2) & TPt 48

R EAEA T

1. 1Tk #¢ Debugger>Select Tool>MPLAB SIM ¥ MPLAB SIM %k {4548, 284 4y i

LT H.

2. JEIETH & E B SO 4 (MyFile.o) SRETIFIESCH . 7RSSO
T KRR Eh BT AT E

PORTB = counter;

SR IE I bR AT B EFE “ Set Breakpoint” (% & W ) .

&l 2-13: BE WA

= MyProject.mcp
[l Saurce Files
o e MyFile.c

MyProject.mow =

=10l x|

#include "p30f6014.h"

int counter: /¢ for TRIZE =
int wain (void)
{

counter = 1;

TRISE = O: ff configure P
while (1) /¢ do forewver
{
PORTE| = meovweor: 44 cend walue
counte oS |E

' m
return 0:  Ereskpoints

Run ko Cursor
Set PC at Cursar

0t

Copy,
Paste
Delete

Add To Project

[dsPrczoreni4 | Advanced Clae il
Bookmarks 3
Text Mode 3
Properties...

FEPRACHD BT O 2230 K5 AR H B PR 2L (0 5 2R W I i 22 B 0

&l 2-14:

VEARRG B O i T A

int counter:

int mwain (void)
i

¥
return 0

[ C:\pic30_toolshexamplesimyfile.c
#include "p30L£6014.h"™

counter = 1;
TRISE = O: /¢ configure PORTE for output
while (1) /¢ do forewver
i
@ PORTE = counter; // send wvalue of 'counter' out PORTE
CoOunter++;

=10l x|

/¢ for TRIZE and PORTE declarations

sl

DS70094C_CN %7 20 7T
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3. ¥k View>Watch 17T Watch % 1. M Add Symbol 5532 ) F 13 i S i ik
#£ counter, #XJ5 miifi Add Symbol.

&l 2-15: WInNEREE &

Mwach e = k|
Add SFHl IAEEA VI Add Symboll Icounter VI

Address | Symwbhol Name | Value I
[uf=]u]n] counter 0xoooo

Watch1  Waich2 [ wiatch 3| watch 4]

VE: B[O geAs . (1) W B Hr, WA ERE, (2D
H#:AE Watch & DT S 4P AR . (3) EJRACHE ik i AR 8 3
i3] Watch % 1,

4. i THE P RUN Z1TFE .

L

FEFPREAERAT BEE T W 0 A 2 0 T o AL o 1 2eil s LR I S (7 Sk g
i) R MEPATHER . watch & 0P BRI counter (0 “17. {8
“17 Dt e R RS, RUASENERE T A,

&l 2-16: BT A

- _ o) x|
Add 5FR ”AEEA vl AddSymboI".bss vl

Address | Symbol Name | Value |
as00 counter oool

[ C:\pic30_toolshexamplesimyfile.c
#include "p30L£6E014.h" /¢ for TRIZE and PORTE declarations

int counter:

int mwain (void)
i
counter = 1;
TRISE = O: /¢ configure PORTE for output
while (1) /¢ do forewver
i
PORTE = counter; // send wvalue of 'counter' out PORTE
COoOunter++;
¥
return 0

sl

© 2005 Microchip Technology Inc. DS70094C_CN 55 21 71
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5. #ili RUN 2kSL2 TR . FEF B4R S0 T while I8 E 25 S 1L AE W S BT
EMAT. Watch & O BoRIEHT ) counter {H A “27,

6. EHODHATHEARM, BIERRIAT—4EA], o] PMEH T AR TR Step Into %
.

]

FEPAT—ANEAR], B G O A2 L2 AR SR 5 Sk BB 248 17 R — NI AT 1IE
i

7. RO ARRE T WAAT L, H ARG BELERE “Remove Breakpoint (i
BRITS) 7o BIAETE Run #41. REFA T HEBHIL “Running...” &, 7£
B, — MBEIARWARF IEAEIZ1T. Run EARA 4K Step BIFREAS Bk
o WRRRAR S L TR, SR T Step MBI AP, FEISAT RIS
T, XL R AR
FHWHEAT IR, A TR Halt $2 4.

oo

—HREFEtrELL,  Step EIAREASFRE KB .

H: VI A PIAREARI 5 1R T . REHOH RS A5 1R
e . FEBATHUY, KO REHOE A TTERAE N, A fras A HEN
BN, T HARER P 1. ElafrBiUr, Bk HIEAE s H
P B WLFRI A i o BP9 P 2 A 2 o
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2.9 AR SO
WS ST A T R AR A A I B InAE B, A8 B PRGN AR S o XN SRl
T A 3 A s i PR S TR A
1. ¥+ Project>Build Options>Project, #XJ rm.ii MPLAB LINK30 i£ i+ .
2. M “Categories” i%t## “Diagnostics” J2Jit “Generate map file” & ik
HE
3. M OK fRTfE & .
4. FEFHEFEINH (Project>Build All) "yt SC 14

B 2-17: AR L St

Build Options For Project “MyProject.mcp™ ﬂﬂ

-

General | MPLAB ASM30 | MPLAB C30 MPLAB LINK3D |

Categories:

i~ Generate Command Line
vV Generate map file
[ Generate cross-reference fil

[~ ‘wam on section realignment

Trace Symbols

Add... |
Remove |
Remave Al |

| It glabal settings Restore Defaults |

I--heap=51 2 Map="$[TARGETBASE] map" -0"$[TARGETBASE). cof

I Use Altemnate Settings

I--heap=51 2 Map="$[TARGETBASE ] map" -o"$[TARGETBASE]. cof

QK I Cancel | Apply |

WU SO (MyProject.map) HHIFETIH H g, wliliilik$¢ File>Open, #XJ5
WA H H ORI IT. B2, “All files(*.)” LM v LAE WIS SCf: . Fifiix
B MyProject.map CAFHIIN SR ULH] T 4F MyProject . C 4miF J5 FE /747 i o A B 17

fif B 1
B 2-2: BRER SO R
Program Memory Usage
section address length (PC units) length (bytes) (dec)
.reset 0 0x4 0x6 (6)
Livt 0x4 0x7c Oxba (186)
.aivt 0x84 Ox7c Oxba (186)
.text 0x100 0xa0 0xf0 (240)
.dinit 0x1a0 0x8 Oxc (12)

Total program memory used (bytes): 0x276 (630) <1%

Data Memory Usage

section address alignment gaps total length (dec)
bss 0x800 0 0x4 (4)
Total data memory used (bytes): O0x4 (4) <1%

© 2005 Microchip Technology Inc. DS70094C_CN 7 23 T
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210 JCZRARPE IR
A NI FIRRES R AE C YRS BT, AERAE C AR e SR R R4S 1
KT AR RGN, HNFEMEILmS. MPLAB IDE $24% 7 a] [a] I5 i £ X
PERPEESR I T B, JF4 T C ACH RN AE B WL 2 b () Bk
1. 1%¥ MPLAB IDE [#) View>Disassembly Listing % 13k 25 F 40 2 AR UL & A= 1,
HIALES A A i ARAS . XX TR S C AR AIC gL KR & FE e, LA
Bt C WA AE LA i #0218 A F 1 o

K| 2-18: RICgRE O

W Dizassembly L =10l x|
e
-—= C:iipie30_toolshexsmplesimyfile.c ol
1 f#include "p30£6014.h" /f for TRISE and PORTE declarations |
Z
3: int counter, temp;
4:
5 int mwain (woid)
-H {
a01an QOFASOOD Ink # dinit tblpage
i counter = 1;

00182 QoZ00010 mov.w #0x1, wi

o01a4 aogs4000 mov.w wi,.bss

I=H

=H TRISE = 0: /f configure PORTE for output
Q0188 QOE00000 mov.w # dinit thlpage,wl

00188 OoEFL1630 mov.w wi, TEISBhits

i0: TRI3A = OxFFFF;

0154 QOEBFOOD setm.w wi

O018C QoEFLE00 mov.w wi, TEISAkits

11: while (1) // do forever

1z: {

13: PORTE = counter; // send wvalue of 'counter' out PORT

a018E Qog04000 mov.w Jhss,.wl

aa1e0 Q051640 mov.w wi,DORTERits
14: temp=T1RXREG;

o018 Qo080 mov.w UIRXREGhits,wd
o0194 aogs4010 mov.w wi, temp

15: counter++;

ool9s Qog04000 mov.w Jhss,.wl

a01es QOEFIO00 inc.w wi,wd

o019a aogs4000 mov.w wi,.bss

a018c Q03 7FFFa bra L2 _ILI
I{I I 3

75 C PACH IR A0 25 T IARREAE PSSO R BA TS o AR R 16 JE AL A5 A Al
R SO AR 2 W 20, SR T Hhk. ST HLES IR kU, 82 a SR
frfifias b bk, FS 21 16 7Y, fdn it dsPIC30F iL4ifE4
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2. k¥ View>Program Memory i I - & FE A7 i % h i HLas i AN g A6 .

A 2-19: PROGRAM MEMORY (FEEFfFfgaR) & HO— 4%
= Program Memory =10 x|
Line Address Opcode Lakel Disassenbly o
188 ao17e 3EZFFF4 hra =z, 0Ox160 —
189 00178  BAD915S thlrdh.b [w5], [WZ++]
190 00174 ES0153 dec.w w3, w3
191 ao17e JAFFF1 hra nz, 0x160
192 O017E [n)-u]ulu]n] return
193 ao1so FAOOOO main Ink #_dinit_thlpage
194 oo01sz Z0ooo1io mov.w H0x1,wd
195 00154 §84000 mov.w wl, . hss
196 oolse 200000 mow . W #_dinit_tblpage,wﬂ
197 ao01ss 851630 mov.w wi, TRISEhits
1958 00154 EES000 setm.w wl
199 aoi1sc §51600 mov.w wi, TRISAhits
Z00 O018E g04000 L L2 mov.w Jbas,wl
Z01 o010 851640 mov.w wi, PORTELits
Z02 o019z §01090 mov.w U1REREGhits, wl
203 oo194 584010 mov. w wl, Cemp
204 oo19a 04000 mov.w .hss,wl
Z05 a019s ESO000 inc.w wl, wd
206 o019ik §84000 mov.w wl, . hss
207 aoi19c 37FFFS hra .LZ
Z08 O019E aooooo nop
09 ao01a0 aoosoo nop -
J - af
Opcode Hexl Machine“ Symbalic | PSY Mixedl PSY Datal

T ITEFE Program Memory & HJEFFIIAFZEI~, il 5ers. J5iG 16

eIt SN

PN
=

1 PSV AR A1 55X PSV 4l J7 XA ARRD .

: KT PSV HWRIEZ A5, S L dsPIC a4 T -

TEATATYEACHD . I 44 A1 Program Memory % IR a] DL & Ik . sbistT
KT BT 1R I RE .
3. Wi R LS B s 1 RI8 4T . 7F Program Memory & 1 s ol JEE 55 )
Symbolic JET K A F A An 5 AD . [ NRS R main a5 AT IF S
B, ZATAN C XX main ()
¥4 RESET #41 (2iik$¢ Debugger>Reset J1i%#¢ Processor Set (AbFEgs &

(VRIS

El

PR I PR AT AR main EVCEWT A

© 2005 Microchip Technology Inc.
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4. BUERE RUN. REPRERCEAE main EAOWT siAL{ 1L

&l 2-20: TR A28 T BT

= Program Memory =18 =]
Line Address Opcode Lakel Disassenbly -
i7s oo1lez 7E0280 wov.w wl, ws =
179 00164 400062 add.w wo,#2,wl
1s0 00166 4550EQD adde.w wl, #0,wl
181 00168  BAS935 thlrdl.b [w5++], [W2++]
15z 00164 ES0153 dec.w w3, w3
153 oo1esC 320008 hra z, Oxl7e
1684 0016E  BAS9Z5 thlrdl.b [w5—-1, [WZ++]
185 Qo170 ES0153 dec.w w3, w3
156 oo17e 320005 hra z, Oxl7e
157 o174 EOOOD4 cpl.w wd
158 oo17e JEZFFF4 bhra z, 0Ox160
189 00178  BAD915S thlrdh.b [w5], [WZ++]
pR=]u} 00174 ES0153 dec.w w3, w3
191 ao17c JAFFF1 bhra nz, 0x160
19z O017E 0s0000 return
€ 193 00150  FAOODOO main lnk #_dinit_thlpage
1594 ooisz Z00o10 mov.w H0x1,wd
195 00154 §84000 mov.w wl, . hss
196 oolse 200000 mow . W #_dinit_tblpage,wﬂ
197 oo1ss §51630 wov.w wl, TRIZEbits
198 00184 §o4000  .LzZ wov.w .has,wl
159 oo1sc S51640 wov.w wl, PORTEbits
200 O015E 04000 mov.w .hss,wl
z01 Qo180 Es0000 inc.w wO,wd
202 o019z §84000 mov.w wl, . hss
203 00154 37FFFA bhra .LzZ
z04 oo1596 Qooooo nop
zZ05 o153 Qoosoo nop -
J ol
Opcode Hexl Machine“ Symbalic | PSY Mixedl PSY Datal

5. RFEIFEXHED (File>Open) FIC4nE 1 (View>Disassembl
Listing) « NAZn LAAERTA =N I & IS . BLAE, nT LLAEATART 2 1 b5
FOBIZATIhAE, KRAEIEET C YA AT E D B A I A .

211 T
ARSI BT BIRLFE . T2 3] (0
« ik it Watch 511 counter RIS DRSS 1.
o 7E counter MU X RO EIR A, EERACTS A AT BT A

counter,
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MICROCHIP AT

53 E HHE 2 —SEI

3.2

AHFEYHR L] MPLAB® IDE #fk A IIEAR “RERR” SCIEG S SEIN BT AR o
i1 dsPIC30F6104 1) Timer1 7= T 4 (1 v ke il it 1 A (1 s 1) 7] B

AP R LUR JUAS 73 20

o AR A

o EFTIH AT RIS

* fii[] MPLAB SIM K PFRAM 28 2047 1

RN B

A FARAR SO

PR SCAF 2 T AE DAg BEASHE A 3 N R PP AR S o R RIRSERR S T LR 7% 5
W TFaG AR PRI, UM AEICRR fa] 50 SCPF e fit 1 C 5 I TEA S R RIS
2o U ) Hr s IS AR P B PR AR RS . BB T MPLAB C30 Y54 A% 1 2 3 H
Re7n Bl CiE ), QIRAR AR 5 AL BREE (SKSCIF . rh T 1) S MR DG
ARG, BLRRT i) el A R P AR 4 QRS B

AR I B A EREOR BN GBI TERE S . AEVFRAROLT, T R
D ] BT 2R UL, K BAT AR IR, AR, AT UG A
AN (A A

Bl 3-1: B SCAF IR TR
#include "p30F6014.h" /* proc specific header */
#define CONSTANT1 10 /* sample constant definition */
int arrayl[CONSTANT1] _ attribute_ ((__space__ (xmemory), _ aligned (32)));
/* array with dsPIC30F attributes */
int array5[CONSTANT2]; /* simple array */
int variablel _ attribute ((__space__ (xmemory)));
/* variable with attributes */
int variable3; /* simple variable */
int main ( void ) /* start of main application code */
{
/* Application code goes here */
}
void _ attribute_ ((__interrupt_ (_ save__ (variablel,variable2)))) _INTOInterrupt (void)

/* interrupt routine code */
{
/* Interrupt Service Routine code goes here */

}

EBERARACS L #include WAL, RE& AR e 4RSS (dsPIC30F6014) 1)
S A BB R R Th B 25 A7 a0 XSk SO o Bl G A — A Ta] A A e L
(#define) , W LAXTILHHTIEMAIRE], KA HFE T — R 5% me Lo

© 2005 Microchip Technology Inc. DS70094C_CN % 27 1T



dsPIC® &=

1= 0=

LTHAAT]

Jr i — N E X, R T e SO R &R e, fR e e s T B, LA
JeeAE dsPIC IIAF S h R 5507 e B8 AN E L, array5, 2 MR

EEiR

FIEH—FE, LU EIE B (variablel) WAIEEEYE (variable3) .
PR KA main () MACIDBE, X BURCE N HAR M o 7E main () JEHZ A
W AR R 25 4 o
SEBR N RS 7 ] B A AR B . SR JE 4, o H T RE L AN 1 2248 4R
% o AHIXNBRO BATEEAE T — AR R TFLR T30 PR A SO AR R >4 1) B4
FHIR SO N B — AN H XA H RS = T I I g 1R

TR ARAFAE dsPIC T R %35 H F 4 4 \support\templates HICAEEA, FEAEH
M \Nasm Fl \c SCAFIeh AL TI0gm A C J5SCfES
T IiE dsPIC30F6014 ] C AR ST 1) 5 2 Y5 A R «

B 3-2:

[ KKK Kok Kk K ok K ok ok kK ok K ok ok ok ok ok K ok kK ok K ok o ok ok ok ok K ok K ok K ok K ok ok k ok K ok K ok ok ok Kk ok K ok K ok Kk ok ok Rk ok Kk Kk K

*

*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*

This file is a basic template for creating C code for a dsPIC30F

device.

TEMP_6014.C #HR SCf4

Copy this file into your project directory and modify or

add to it as needed.

Add the suitable linker script (e.g., p30£6014.gld) to the project.

If interrupts are not used, all code presented for that interrupt
can be removed or commented out with C-style comment declarations.

For additional information about dsPIC architecture and language

tools, refer to the following documents:

MPLAB
MPLAB
dsPIC
dsPIC
dsPIC
dsPIC

C30
C30
30F
30F
30F
30F

Compiler User's Guide
Compiler Reference Guide

Assembler, Linker and Utilities User's Guide :
: DS70046

16-bit MCU Family Reference Manual

Sensor and General Purpose Family Data Sheet :
: DS70030

Programmer's Reference Manual

Template file has been compiled with MPLAB C30 V 1.3.

Ak k kK kK kK kA ok k ok k kA kA kA k kA kA kA kA kkk Ak Ak kkkhkhkkhkkhkhkhkhkkhkhkkkkkkkkkk k%

Author:

Company:

Filename: temp_6014.c
Date: 08/20/2004
File Version: 1.30

Other Files Required: p30F6014.gld, libpic30.a
Tools Used: MPLAB GL -> 6.60

Compiler -> 1.30
Assembler -> 1.30
Linker -> 1.30

Devices Supported:

dsPIC30F2011
dsPIC30F3012
dsPIC30F2012
dsPIC30F3013
dsPIC30F3014
dsPIC30F5011
dsPIC30F6011
dsPIC30F6012
dsPIC30F5013
dsPIC30F6013
dsPIC30F6014

Ak ok k kK kK kK kA kA kA kA kA kA kkk kA kA kA k Ak Ak Ak Ak khkhkkhkhkhkhkhkhkhkkkkkkkkkk k%

: C30.pdf
: R30.pdf

ALU.pdf

DS70083

*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*

B g

*

* Other Comments:

*

*

*

*

DS70094C_CN 3 28 71

© 2005 Microchip Technology Inc.



IR 2

SE I H BT

*

*

1)

C attributes,
means to specify various characteristics of a variable or
function, such as where a particular variable should be placed
in memory, whether the variable should be aligned to a certain
address boundary, whether a function is an Interrupt Service
(ISR), etc. If no special characteristics need to be
specified for a variable or function, then attributes are not
required. For more information about attributes,
C30 User's Guide.

Routine

refer to the

The _ space_ (xmemory) and __ space__ (ymemory) attributes

are used to place a variable in X data space and Y data space,
respectively. Variables accessed by dual-source DSP instructions
must be defined using these attributes.

The aligned (k) attribute, used in variable definitions, is used
to align a variable to the nearest higher 'k'-byte address
boundary. 'k' must be substituted with a suitable constant
number when the ModBuf X (k) or ModBuf Y (k) macro is invoked.

In most cases, variables are aligned either to avoid potential
misaligned memory accesses, or to configure a modulo buffer.

The _ interrupt_ _ attribute is used to qualify a function as an
interrupt service routine. An interrupt routine can be further
configured to save certain variables on the stack, using the
__save__ (var-list) directive.

The _ shadow__ attribute is used to set up any function to
perform a fast context save using shadow registers.

Note the use of double-underscores (_ ) the start and end of
all the keywords mentioned above.

at

designated by the _ attribute__ keyword, provide a

*

*

ok ok ko ok ok K ok K ok ok K ok ok K ok ok ok ok K ok ok K K ok K ok ok K ok ok K ok ok ok ok K ok ok K ok ok K ok ok K ok ok K ok ok ok ok K ok ok K ok kK ok ok K ok k Kk k ok ok /

/* Include the appropriate header (.h) file, depending on device used */
/* Replace the path shown here with the header path in your system */
/* Example (for dsPIC30F5013): #include "Your path\p30F5013.h" */
/* Alternatively, the header file may be inserted from the Project */
/* window in the MPLAB IDE */
#include "p30F6014.h"

/* Define constants here */

#define CONSTANT1 10

#define CONSTANT2 20

/* Define macros to simplify attribute declarations */

#define ModBuf X (k) _ attribute_ ((__ space__ (xmemory), _ aligned_ (k)))
#define ModBuf Y (k) _ attribute ((__ space_ (ymemory), _ aligned (k)))
J*FAF KA KK KK KKk START OF GLOBAL DEFINITIONS ****xk*k*x /

/* Define arrays: arrayl[], array2[], etc. */

/* with attributes, as given below */

/* either using the entire attribute */

int arrayl[CONSTANT1] _ attribute_ ((__space__ (xmemory), _ aligned_ (32)));
int array2[CONSTANT1] _ attribute_ ((__space__ (ymemory), _ aligned (32)));
/* or using macros defined above */

int array3[CONSTANT1] ModBuf X (32);

int array4 [CONSTANT1] ModBuf Y (32);

/* Define arrays without attributes */

int array5[CONSTANT2];

/* array5 is NOT an aligned buffer */

© 2005 Microchip Technology Inc.
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/‘k ________________________________________________ */
/* Define global variables with attributes */
int variablel _ attribute ((__space__ (xmemory)));
int variable2 _ attribute__ ((__space__ (ymemory)));
/* Define global variables without attributes */

int variable3;

JxFr KAk kKkkkkk** END OF GLOBAL DEFINITIONS ****x**kkk*x /

J*r KKk kkkkkkxkk START OF MAIN FUNCTION ** %k %k kokkkkk k% /

int main ( void )

{
/* Code goes here */

}
/***%%% START OF INTERRUPT SERVICE ROUTINES *****x*¥x/

/* Replace the interrupt function names with the */
/* appropriate names depending on interrupt source. */

/* The names of various interrupt functions for */
/* each device are defined in the linker script. */
/* Interrupt Service Routine 1 */
/* No fast context save, and no variables stacked */
void _ attribute_ ((__interrupt_ )) _ADCInterrupt (void)
{

/* Interrupt Service Routine code goes here */
}

/* Interrupt Service Routine 2 */
/* Fast context save (using push.s and pop.s) */

void _ attribute_ ((__interrupt__, _ shadow__)) _TlInterrupt(void)

{

/* Interrupt Service Routine code goes here */

}

/* Interrupt Service Routine 3: INTOInterrupt */

/* Save and restore variables varl, var2, etc. */

void _ attribute ((__interrupt (_ save (variablel,variable2)))) _INTOInterrupt (void)
{

/* Interrupt Service Routine code goes here */

/***xxxx%% END OF INTERRUPT SERVICE ROUTINES ******%x/

DS70094C_CN 30 7T
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3.3

FEHTIH H A8 AR

W T IEANERE, nlal i LU B0 Bk i A BRI BT I H H b . T BATE
Windows'® 7 U5/ L3 b SR | SCREEATRAR .
1. 7£ MPLAB C30 %% H3k N \Examples HagPld—"14R
\T1l Interrupt BT A
2. $f Cc:\pic30 tools\support\templates\c\temp 6014.c K lZXHr
M \T1 Interrupt XK.
3. ¥ \T1 Interrupt AR EZHIFIBMR M temp 6014.c AN
T1lClock.co,
4. 1R[1] MPLAB IDE.
IR 2T “HEA— QBB ” hrpbBRAEHIH m SRR H kb el — AN
JiH T1Clock, ¥ T1Clock.c fEAME—MUESCARAR MBI H b, FF7 N
dsPIC30F6014 iR SCfF . AR5 W I H & H P S0 44 T1C1lock. cr SEIITHY
R B s

Kl 3-1: &% T1CLOCK.C

% MPLAB IDE v6.60.03 : =lof x|

File Edit “iew Project Debugger Programmer Tools Configure  Window Help
| DBE| i me 82 | cec@BBa 26
o

£l TiClock.mcp
[=)- Source Files

Il C:'\pic30_tools' examples’, T1_Interrupt'T1Clock.c
*ﬁ‘ﬁ‘ﬁ*ﬁﬁ‘ﬁ‘ﬁﬂ‘*ﬁ‘tﬁ**ﬁ‘ﬁ‘1“1“1“ﬁ‘ﬁ‘ﬁ**ﬁ‘tﬁ**ﬁ‘tﬁ1“1“%‘ﬁ‘ﬁﬂ‘*ﬁ‘tﬁ**ﬁ‘tﬁ**ﬁ‘#ﬁ**ﬁ‘ﬁ‘ﬁ**ﬁ‘tﬁA
* This file is a basic template for creating © code for a dsPICS
* dewvice. Copy this file into your project directory and modify
* add to it as needed.

* idd the suitable linker script (e.g., p30fe0l4.gld) to the pro

*

- Other Files

* If interrupts are not used, @ll code presented for that interr

* pan be removed or commented out with C-style comment declarati
-

W - o 1 B D Bd

* For additional information about dsPIC architecture and langus
* tools, refer to the following documents:

*

* MPLAE C30 Comwpiler User's Guide o Dasiz
* dsPIC 30F MPLAE ASM30, MPLAE LINKIO and TUtilites

w User's Guide : DSSlSv
S - S S Y S . nﬂ-.:_l

[dsPIcanFen14 [oabsabIP0 [denovac [ [tnt, Colt NS [wR
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PUAE AT A AN AR L8 SISO R B, R Y 1 B i A\ 2008 14 0
H o SCPEIT SRR Sk SO B 00 B A 5008 0 H KA B e g e iia s Boas b

& 3-2: A8 JE 1 TICLOCK.C L3t

[ C:\pic30_toolshexamplesiT1 InterruptiT1Clock c* i ;|g|5|
[T [ /rrrrrrrrrrrrnnrrrannrrrararsrarnnrranararannna TR R AR AR TR AR AT R TR —
2 * *

3 * Author: F. Bar *

4 * Company: Widgets, Inc. *

= * Filename: TiClock.o *

6 * Date: 01/7/2003 *

7 * File Version: 1.00 *

(=] * Other Files REegquired: p30F&6014.gld, libpic30.a *

S * Tools Used: MPLAE GL -> 6.2Z0 *

10 * Compiler -> 1.10 *

11 * bssembler -> 1.10 *

1z * Linker -= 1.10 *

13 1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“1“******t*ﬁ********ﬁ*****f

14

15

16 #include "ocihpic30 tools\supporthh' p30Fe014.h™

17 B

18 #cdefine CONSTANTL 10

19 #odefine CONSTANTZ 20 -
T of

EXA R, T E L — N E. WNRERN N B s RSN
CONSTANT1 Fl CONSTANT2. XA S e XiER . 7 CONSTANT2 171 T
INI—ATERB AN TMR1T  PERIOD 0x1388 M X:

/* Timerl period for 1 ms with FOSC = 20 MHz */

#define TMRliPERIOD 0x1388

VE: JEI3 0x1338= |- il%k 5000, &N 25 TH R 2 PR 2 1 1/4. £
5MHZ (20MHZ $&3% #5090 45) K 5000 AN A, HHEes ks 1ms HEL—
W H
TEA Hpa] DL S— S8R AR A 3 E AT BR B . T LAYE GLOBAL DEFINITIONS
53 variable3 jE XJm g XA & . NP BT 284 & main counter Fll
irqg counter. #ARJF, AEM &P WRSFEFEIE D BA A TR HERAR & A 0L
timer. ticks fll seconds. %A RTclock HIZEK:

1 3-3: ge X

/* Define global variables without attributes */

int variable3;

int main counter;
int irg counter;

struct clockType
{

unsigned int timer; /* countdown timer, milliseconds */
unsigned int ticks; /* absolute time, milliseconds */
unsigned int seconds; /* absolute time, seconds */

} RTclock;

DS70094C_CN % 32 11 © 2005 Microchip Technology Inc.
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XA HORE A RS A T LLOR B s R o RIS AT VR R i v e BE A —
NI 5 SCos g eI T A A ). BA DK I A R I B R, B e Al
FIT AT ATE R 20 SCo B RIS R, AR S A MR A i I P R P 1
WL S AR S A AT 11

H: FEAL PR, S AT TR g 5 R ACHS I A 2] 2 A AR T 3= .
Abs TEREREAAL ] AR HR 23 REARAT K, IXAEAE LR i ZER BT I,
F AR BB 5

FEHRIC N END OF GLOBAL DEFINITIONS MBS M NIX A%, i F Py i-ioks
Timer 1 WAL R — A WTE N2 CRUATRE 4 RO 2

5] 3-4: RESET_CLOCK {74

JHxrFkKkxkkKkkkkxkk* END OF GLOBAL DEFINITIONS ****kkxskkx*/

void reset_clock (void)
{
RTclock.timer = 0;/* clear software registers */
RTclock.ticks = 0;
RTclock.seconds = 0;
TMR1 = 0;/* clear timerl register */
PR1 = TMR1_PERIOD;/* set periodl register */
T1CONbits.TCS 0;/* set internal clock source */
IPCObits.T1IP = 4;/* set priority level */
IFSObits.T1IF 0;/* clear interrupt flag */
IECObits.T1IE = 1;/* enable interrupts */
SRbits.IPL = 3;/* enable CPU priority levels 4-7 */
T1CONbits.TON = 1;/* start the timer */
}

JxHFx KAk kKkkKkkk* START OF MAIN FUNCTION ***kkkkkkxkkkxk /

XA REAE ] T L3 p30F6014 . h H0E IR T RE 27 /245, 4 TMR1 Al
T1CONbits.TCS. KT Timerl [IXLe= B M T A28 M 25 R, S H LT
JiligS

AIRETR B0 S L R AR TP W IR S 27 . TP IR S FR P R 24N AR . B ALE Timer1
T4 0x1388 A AR HAT . R 1ms [ Wrsh B8 713088 sticks, HFI 1000 K
1o RJGIBMZEH) RTclock FIA & seconds, JFHEAI sticks. XAFEFLLFSK
K ) HEAT T 8. ZEARiC “START OF INTERRUPT SERVICE ROUTINES” [H#57>
, 758 TlInterrupt () AAAS%4GSE RIBRk AL, H R HAARRAT GRS ER
) BWER “/* Interrupt Service Routine code goes here */”:
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1 3-5: T R S5 AR

/* Interrupt Service Routine 2 */
/* Fast context save (using push.s and pop.s) */
void _ attribute_ ((__interrupt__, _ shadow__)) _TlInterrupt(void)

{

static int sticks=0;
irq counter++;

if (RTclock.timer > 0)/* if timer is active */
RTclock.timer -= 1;/* decrement it */

RTclock.ticks++;/* increment ticks counter */

if (sticks++ == 1000)
{/* if time to rollover */
sticks = 0;/* clear seconds ticks */
RTclock.seconds++;/* and increment seconds */

}

IFSObits.T1IF = 0;/* clear interrupt flag */

}

/* Interrupt Service Routine 3: INTOInterrupt */
/* Save and restore variables varl, var2, etc. */

TERR AT A = Al ek £, R INTOInterrupt (), B EATH T4
BSR4 %.  ADCInterrupt () Al DLAER I, K47
AREFEPHAZIE

5 Timer 1 hIWiRISAHEL, main () fORS LR . £E P N I AARAS, B
“/* code goes here */” 4T CGRINAACHS A FHAAZST)

1) 3-6: F R EARUNG

[ Rk KKk kkKkkkkxkkk START OF MAIN FUNCTION ** %k %k kokkkkk k% /

int main ( void )
{

reset_clock() ;

for (;;)
main_counter++;

}

/*****x*x START OF INTERRUPT SERVICE ROUTINES ******%%x/

main () U FEXS Timer 1 WILAAL A, 52— AN CRRIEIR, foVF Timer 1
Wr TAE. —JEERSO0 N, A0 S IS 28 ) S PR B A 1K AN ER A, AR AR

main counters.
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1 3-7: AR C Rt

[ KK K kK ok K ok K ok K ok ok ok K ok K ok ok ok ok kK ok ok K ok K ok ok ok ok ok ok K ok K ok K ok o ok ok ok ok K ok K ok Kk ok Rk ok K ok ok kK ok Kk Rk ok K ok ok kK

*

* Author: F. Bar

* Company: Widgets, Inc.

* Filename: T1lClock.c

* Date: 08/20/2004

* File Version: 1.30

* Other Files Required: p30F6014.gld, libpic30.a
* Tools Used: MPLAB GL -> 6.60

* Compiler -> 1.30

* Assembler -> 1.30

* Linker -> 1.30

*

*

*

*

*

*

Kok ok ok kK k Kk kk ok ok ko k Kk kkkkkkhkhk Ak kkhhkkkkhkkhkhhkkkk Kk khkkhkkkk Kk kkkhk Kk Kk kA kk*x /

#include "c:\pic30_tools\support\h\p30F6014.h"

/* Define constants here */
/* #define CONSTANTI1 10

#define CONSTANT2 20 */
/* Timerl period for 1 ms with FOSC = 20 MHz */

#define TMR1 PERIOD 0x1388

/* Define macros to simplify attribute declarations */

#define ModBuf X (k) _ attribute ((__ space__ (xmemory), _ aligned (k)))
#define ModBuf_ Y (k) _ attribute_((__space__ (ymemory), _ aligned_ _(k)))

[ *xxxxkkkkkkkk START OF GLOBAL DEFINITIONS ks /

/* Define arrays: arrayl[], array2[], etc. */
/* with attributes, as given below */
/* either using the entire attribute */
/*
int arrayl[CONSTANT1] _ attribute__ ((__space__ (xmemory), _ aligned__ (32)));
int array2[CONSTANT1] _ attribute ((__ space__ (ymemory), _ aligned_ (32)));
*/
/* or using macros defined above *x/
/* int array3[CONSTANT1] ModBuf_ X(32);
int array4[CONSTANT1] ModBuf Y (32); */
/* Define arrays without attributes */

/* int array5[CONSTANT2]; */ /* array5 is NOT an aligned buffer */

/* ________________________________________________ */
/* Define global variables with attributes */
/* int variablel _ attribute_  ((__space__ (xmemory)));
int variable2 _ attribute ((_ space  (ymemory)));*/
/* Define global variables without attributes */

/* int variable3; */
int main_counter;
int irg_ counter;

struct clockType
{

unsigned int timer; /* countdown timer, milliseconds */
unsigned int ticks; /* absolute time, milliseconds */
unsigned int seconds; /* absolute time, seconds */

} RTclock;

© 2005 Microchip Technology Inc.
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JxFrKkKkkKkkkkk** END OF GLOBAL DEFINITIONS ******xkkk*x /

void reset_clock(void)
{

RTclock.timer = 0; /* clear software registers */
RTclock.ticks = 0;

RTclock.seconds = 0;

TMR1 = 0; /* clear timerl register */

PR1 = TMR1_PERIOD; /* set periodl register */
T1CONbits.TCS = 0; /* set internal clock source */
IPCObits.T1IP = 4; /* set priority level */
IFSObits.T1IF = 0; /* clear interrupt flag */
IECObits.T1IE = 1; /* enable interrupts */
SRbits.IPL = 3; /* enable CPU priority levels 4-7 */
T1CONbits.TON = 1; /* start the timer */

/************* START OF MAIN FUNCTION ***************/
int main ( void )

{
reset_clock();

while (1)

main_counter++;

/****xx START OF INTERRUPT SERVICE ROUTINES ****#**skkx/

/* Interrupt Service Routine 1 */
/* No fast context save, and no variables stacked */
/* void __attribute_ ((__interrupt_ )) _ADCInterrupt (void)
*/
/* Interrupt Service Routine 2 */
/* Fast context save (using push.s and pop.s) */
void _ attribute_ ((__interrupt__, _ shadow__)) _TlInterrupt(void)
{
static int sticks=0;
irg_counter++;
if (RTclock.timer > 0) /* if countdown timer is active */
RTclock.timer -= 1; /* decrement it */
RTclock.ticks++; /* increment ticks counter */
if (sticks++ > 1000)
{ /* if time to rollover */
sticks = 0; /* clear seconds ticks */
RTclock.seconds++; /* and increment seconds */
}
IFSObits.T1IF = O; /* clear interrupt flag */
return;
}
/* Interrupt Service Routine 3: INTOInterrupt */
/* Save and restore variables varl, var2, etc. */
/* void __attribute_ ((__interrupt__ (__save__(variablel)))) _INTOInterrupt (void)
*/

/****x*%x+ END OF INTERRUPT SERVICE ROUTINES

Kkkk kKKK [

R N IERG, PR Project>Build All 7 LIAS R S 0 gm0 . a0 R HR, Wi
Output & DR SR R BEARRD h, B R AR IE g e e, H R R
Jik.
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3.4

{#Fl MPLAB SIM A4 AR 24T 7R

WAE, WLLH MPLAB SIM # A fil s HRARAS T o PRIk $E T Debugger>Select

Tool>MPLAB SIM . %X J5i%+$% Debugger>Settings %8 1) b P 2% s ofrik 155 354 T 8¢
Ho fE¥RY Ay (OsclTrace) EI-RAIHHEH, W] DL ERHU dsPIC30F6014 1
PR o R IR 1 20MHZ.

H: BAPBHUSS IS TR th PC HLIRZE, Bt LLE AN AT BE LA 1R AE B & Y
dsPIC30F MCU )56 b Bz AT H2, BT IR e Nk S0t 2 T IX AN
BRACET, BRI, A PRI HEAT IN PR S Ny, W I ) S A
IR B S BRI AT I LA A o

A& 3-3: BT a5 A
Uart] 10 | [ebugger Animation I Limitations I
Osc / Trace Ereak Dptions I SCL Options
~ Processzor Frequency .
* MHz
20 " KHz
" Hz
r~ Trace Options
[T Trace al [™ Break on Trace Buffer Ful
QK I Cancel | Apply |

FHRSEALL 2800 5 B8 (0] () — AN vk e A H ML R Dh e .
Stopwatch (Hi3R) XUEHE, #fifRiET “Clear Simulation on Reset” & IEAE.

] 3-4:

1 F Debugger>Stopwatch KT T

AR R
1ol x|
Stopwatch Total Simulated
Synchl Instruction Eyclesl 0 I 0
Zem | e (o8eEs) | 0.000000 | 0.000000
‘ Processor Frequency  [MHz ) I 20.000000 ‘

¥ Clear Simulation Time On Feset

© 2005 Microchip Technology Inc.
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dsPIC® E=T AN

HARERDIUE—TF, FPREMEIZIT. Ak, ATBYE main () By
main_counter FAUIAT EBE Ml (FEIZAT L rlili AR BTk +E “Set
Breakpoint” ) , #AJ5 sithi RUN ElFREE$: Debugger>Run. #2/7iafTRIWifi)E,
F B E TR

A 3-5: I TR &

% MPLAB IDE ¥6.60.03

=10l x|
File Edit Wiew Project Debugger Programmer Tools  Configure  Window  Help
|PSE s mA[EH? coEBw S8
[vuveee|
o 1cockmen ST

= TiClock.mcp

Stopwatch =101 =1

Stopwatch Total Simulated

Instruction E}lclesl 105 I 105

frrwwwwaawwass ITART OF MAIN F1 ZFerg | Time [uSecs] I 21_000000'
int wain [ void |

Other Files {

reset_clock(): ‘ Processor Frequency [ MHz ) 20.000000 ‘

[V Clear Simulation Time On Reset
while (1)

21.000000

main_counter++;

¥

Juwrxss START OF INTERRUPT ZERVICE ROUTIMNES #wwsaswww/
/% Interrupt Service Routine 1 w
/* Mo fast context save, and no varisbles stacked =
/% woid _ attribute  ((_ interrupt_ )]

_ADCInterrupt (void)
=

[MPLAE SIM [ |dsPICa0Fe014  [pe:Oxibe  |oabsabIP3 [DCnovzC [ [ [

| lwe 4

WRIZAT T, e LA & — Watch & DRGSR 1A 5. % View>Watch 3k
P Watch % H . N4 & RTclock (M Add Symbol 55340 /) F FAEHEFR) .

Rtclock st NEH, 1EUWIILA P/ JrHE R /IS B . i JTHES] TFIX AN &5
s E s

A 3-6: MELRE

OS]
Add SFHl IAEEA VI Add Symboll IHTclock VI

Address | Symwbhol Name | Value I
0506 E RTelock
timer

-~ ticks Ox0000

0808
0BOL e EEERES Ox0000

[wiatch1 Watch2| Watch3| Watchd]

F* Rtclock 4b, 7& Watch & HH A INAS & sticks. irg counter Al

main_counter.
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E=N

& 3-7: P s &
Add SFHl IAEEA VI Add Symboll Imain_c:ounter j
Address | Symwbhol Name | Value I

0806 B RTclock

0806 i timer 0x0000
as0s ticks Oxooo0o
0s0L seconds Ox0000
sticks out of Scope
0304 irg counter 0x0000
0502 main counter 0x0000

[wiatch1 Watch2| Watch3| Watchd]

A LA Value 1X—51 47 58 LMEELE] sticks BEAX —FITHNE. IREERCES
“Out of Scope” . EMZE#i, 5 Rtclock. irg counter Mlmain counter A
[, EARE—AN2REE, HAEPITHRE Tlinterrupt () BA BN & RHEEAT
il

H: sticks ML A KH— KR ER AR R,

W IR PAT R RN, A Watch & HH AR, iR SE T 00 iX 2 nl DB
fift iy, RO B Timer 1 NINIBEHI464E, 110 counter MEE IR —IEIE

riih Step Into EFRHELHAT —IK main () fE#. K, main counter WMEERN
0001, "I FEFIREA ). #iF Stopwatch % 11, HEA main () EFH IR (]
S A kb e BEHENEE kP, 2 AT 1000 (XAEFR (1000 x 1 us =1 ms) .
T R T Dy e, R ST b A B s R T AT L RE “Remove Breakpoint”
KEHKES main counter++ R ARJGEFA T AR “Set
Breakpoint” 7E Wi FEF ) irg counter++ i) BE — Wi Al. BNk
ifi Run. Stopwatch % I8 sl .

K 3-8: H—F W) STOPWATCH % O

=101 x|

Stopwatch Total Simulated

Inztruction Eyclesl 5108 I 5108
Zera | Time [mSecs ] ﬁ 1.021600 | 1.021600

‘ Processor Frequency [M I 2D.DDDDDD‘

¥ Clear Simulation Time On Feset

Stopwatch ] Time % 1 B/~ A 1.0216ms. IEWFATA K, 24—
KW AT R BONE], AUHE C B A Timer 1 WIAGAL IR A), R0
H T I B .
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i Watch % M. A5 main _counter WxME A OX3E8. % I 410 SR n] oy il /s

H St -

1. Miimain counter i&# Watch & 47, 2RJE, Al FH PR A BRI $%
“Properties” .

2. {£ Watch X 1iFHE[¥) Watch Properites 2E30 1, M “Format” "¢ furpik £
“Decimal” .

3. siili OK.

& 3-9: RENEEH
watch 21X

" atch Properties | Preferencesl Generall

Symbol:lmain_counter - l
Size: I‘IB bits: 'l

Farmat: | D ecimal v Signed
Byte Order: |High:Low -

Memory: IFiIe Fegister
QK | Cancel | Apply | Help |

WAE main counter FMEMN W< K 1000. £ X st Step Into Elbr B AL i 1) 1
UL, Hpilit sticks Ml irg counter, f/7AE—IRTWrE N FIEAR LIS
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3.5

IS

Bl irq_counter++; 17 LHIWI AL, FEWr i BAE NS sticks

sticks =

Mz fFEa s (FF

0; IX—A7) o mili Run I847 JH45 I AE W s & OB Won

A& 3-10: T i A
wmep =10i]
ce Files
“1Clock.c
fer Files Stopwatch Total Simulated
: Il C:,pic30_tools examples', T1_InterruptiT1Clo Instruction Eyc:lesl smiizs I 28
|
i+ RTolock. timer —= | ZFero | Time [Secs ]ﬁ 1.002226 I 1.002226
w104
| 122 S S ‘ Processor Frequency m lm ‘
107 R (SRdehir A0 ¥ Clear Simulation Time On Feset
108 {
108 S sticks = O:
110 RTclock.seconds++; /% and increment seconds ¥/
111 }
11z
113 IF30hits.T1IF = 0O; /% olear interrupt flag %/
114 J
115 return;
118 }
117 -
14 e e e me e e . :J_J

Stopwatch ] Time % 1 @7~k 1.002226 7,

KL R 1 BRI W HERA (1 1]

BT S e e N Y e S N 1 PPNy = Y N = < 9 11 Y R e e O (S = U 2 4
AT I F 2 P R W 2 ] R (1) — 4% T Stopwatch XIS HEF 1) Zero, $E 154%

Run. [K2xf 1AL BEgsH] T 2 KK A2 1T BX A DAL T

H: B B AR U HE AT I ) T 1 R R RN 1) o 223 )
MEEAT T 32T Zero Avax T BUR RIS R A& 2E A

CARREEE S oy IV

GRELSC— N R RBIRESF . HERE— 202 2] N A5

o DETWIEITE, RIS R INE; WE SR R TMR1 Period MK

A PR T LARAS HEAF IR 1 D HER S

o AT SO ] CBA B LD 22 /b2 fi e $i v Pl i [ 2
o W ASTRY, AR SRR A 2 2R RKR . A B ARG AIE K o ) 5

i3
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MICROCHIP AT

4% HR3— RAMA C IS gA

4.2

AHRERE A AT QMRS A C SCPFRE g ST H i C JSCH AE
HiiEE TR

AHRE AT J LA 4Lk s

o IRAFIH PSCAF

o R REI H

© WA

* WA

o A JatnffE

R H I

AREFE AL ) SO IR \Examples AP 4T, A1 02 C JHEACRS 34
example3.c VLGS A modulo.s. fF \Examples XHJerp g —N4 N
\DSP_ASM ST, FHAX A ST I BB et i i > %8 3 ]| “H
T2 2 —SERHhl” .

e 22, # 4-1 T 4-2 25 T IX A SRR s

% 4-1: C JE3CH

[ kK ok ok ok ok ok K ok ok ok ok K ok ok K ok ok K ok ok K ok ok K ok K ok ok K ok ok K ok ok K ok ok K ok ok K ok K ok ok K ok ok K ok ok o ok kK ok K K ok Kk ok Kk kK ok k

* Filename: example3.c *
Date: 08/20/2004 *
File Version: 1.30 *
Tools used: MPLAB -> 6.60 *
Compiler -> 1.30 *

Assembler -> 1.30 *

Linker -> 1.30 *

Linker File: p30£f6014.gld *
*

*
*
*
*
*
*
*
R R R R

/

#include "p30£6014.h"
#include <stdio.h>

/* Length of output buffer (in words) */
#define PRODLEN 20

/* source arrays of 16-bit elements */
unsigned int arrayl[PRODLEN/2] _ attribute_ ((__ space__ (xmemory), aligned(32)));
unsigned int array2[PRODLEN/2] __attribute_ ((__space__ (ymemory), aligned(32)));

/* output array of 32-bit products defined here */
long array3[PRODLEN/2]; /* array3 is NOT a circular buffer */

/* Pointer for traversing array */
unsigned int array_index;

/* 'Point-by-point array multiplication' assembly function prototype */
extern void modulo( unsigned int *, unsigned int *, unsigned int *, unsigned int );

int main ( void )

{

/* Set up Modulo addressing for X AGU using W8 and for Y AGU using W10 */

/* Actual Modulo Mode will be turned on in the assembly language routine */
CORCON |= 0x0001; /* Enable integer arithmetic */
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XMODSRT = (unsigned int)arrayl;
XMODEND = (unsigned int)arrayl + PRODLEN - 1;
YMODSRT = (unsigned int)array2;
YMODEND = (unsigned int)array2 + PRODLEN - 1;

/* Initialize 10-element arrays, arrayl and array2 */
/* to values 1, 2, ...., 10 */
while (1) /* just do this over and over */

{

for (array index = 0; array index < PRODLEN/2; array index++)

{
arrayl[array index] = arrayl[array index] + array_index + 1;
array2[array_index] = array2larray_index] + (array_index+l) * 3;
}
/* Call assembly subroutine to do point-by-point multiply */
/* of arrayl and array2, with 4 parameters: */
/* start addresses of arrayl, array2 and array3, and PRODLEN-1 */
/* in that order */

modulo ( arrayl, array2, array3, PRODLEN-1 );

1 4-2: MODULO.S JC4iFE 3t

[ kK ok ok ok ok ok K ok ok ok ok K ok ok K ok ok K ok ok K ok ok K ok ok ok ok K ok ok K ok ok K ok ok K ok ok K ok ok ok ok K ok ok K ok ok K ok kK ok K K ok ok kK ok ok Kk ok

* Filename: modulo.s *
* Date: 08/20/2004 *
* File Version: 1.30 *
* *
* Tools used: MPLAB -> 6.60 *
* Compiler -> 1.30 *
* Assembler -> 1.30 *
* Linker -> 1.30 *
* *
* Linker File: p30£f6014.gl1d *
* Description: Assembly routine used in example3.C *

ok ok ok ok ok K ok K ok ok K ok ok K ok ok ok ok K o ok K K ok K ok ok K ok ok K ok ok ok ok K ok ok K ok ok K ok ok K ok ok K ok ok K ok Kk ok K ok ok ok ok ok Kk ok Kk k ok k[

.text

.global _modulo
_modulo:

; If any of the registers W8 - W15 are used, they should be saved
; WO - W7 may be used without saving
PUSH w8
PUSH W10

; turn on modulo addressing
MOV #0xCOA8, W8
MOV W8, MODCON

; The 3 pointers were passed in W0, Wl and W2 when function was called
; Transfer pointers to appropriate registers for MPY
MOV wo, W8 ; Initializing X pointer
MOV Wl, W10 ; Initializing Y pointer

; Clear Accumulator and prefetch 1lst pair of numbers
CLR A, [wW8]+=2, W4, [W1l0]+=2, W7

LSR W3, W3

RCALL array_loop ; do multiply set

INC2 W8, W8 ; Change alignment of X pointer
RCALL array_loop ; second multiply set

POP W10
POP w8
RETURN

; Return to main C program

array loop:
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; Set up DO loop with count 'PRODLEN - 1' (passed in W3)
DO w3, here

; Do a point-by-point multiply
MPY W4*W7, A, [W8]+=2, W4, [W10]+=2, W7

; Store result in a 32-bit array pointed by W2
MOV ACCAL, W5
MOV W5, [W2++]

MOV ACCAH, W5
here: MOV W5, [W2++]

; turn off modulo addressing
CLR MODCON

RETURN

.end

43 QRN FEIH
fliH] Project Wizard  (JSUH 1) , BIEE—ASHTIH ,  FHRFIX I SCPE AT HE SC

fF p30£6014.gld IMEIXATIH . RAMENS 27 “HE 1 — QWA .
TUH B FN R B s

A 4-1: i H &1

=

= Example3.mcp
- Saurce Files

[ example3.c

----- modula.s

Header Files

Object Files

- Library Files

- Linker Scripks

- p30fE014.g1d

- ther Files

ABREG A FHFRUER) 1/O BR% print £ () £F Output i) % H b oy B . 24
printf (), MELEHEREA Build Options (ZmPeikmii) rfifedE. i fnbkds odgm i
GEIR B E K 2-8 o, AHESEL T 512 TS AS A,

GBI H I (Project> Build Al , RN USRI B 0 BB R, EHA
T AE R T P AN BOREAR R (P aE T e S T 30 H

AREFEAEH T = A0 b AN AR R MRS, AR5 TR R A 16
RrEC AP AR T, W45 SAEIE S = 32 fr e b . i P Sl JE ki s e A
TVUCRIEE IR TR R ) Her AN B A R R SO TR 5 o, AR B A 4
WGBS, R A b P AP IR . W miE SRR, FIH dsPIC30F6014 1
DSP ZhfgidtiTia 5,

4B SHEFEUANSE: AR K, 45 IR R R B4 .
XAFEFELLPEINIEAT, MR EE AT EICIRAEERS, YR B A O AR 18 k.
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Es LA

— B H G2 i I e, vl LUEH MPLAB SIM #4F 154 (Debugger >
Select Tool > MPLAB SIM ) R &R 4/E. 7F example3.c AL YiE 5 TP

modulo () HYPREL b i BT RFIZAT BT 5

& 4-2: C AR A B T A

M C:'.pic30_tools' examples,DSP_ASM'\example3.c ;|g|5|
46 while (1) /% just do this over and over */ j
47 i
45
49 for [(array index = 0; array index < PRODLEN/Z: array ind
50 { B B B
51 arrayl[array index] = arrayl[array index] + array im
52 arrayi[array index] = arrayi[array index] + [array i
=3 } - - -
54
55 /% Call assenbly subroutine to do point-by-point multiply W
56 /% of arrayl and arrayZ, with 4 parameters: wl
57 /% start addressesz of arrayl, arrayZ and array3, and PRODLEN-1 *,
58 f% in that order &l
59 o I modulo | arrayl, arrayiZ, array3i, PRODLEN-1 |:
60 '
61 '
G2

-
| o

WE Watch & SR & H I H T LW E. R hm =M arrayl. array?
Ml array3. BERINGHKIIGES 7% (Special Function Register, SFR) ACCA.
WREGS Fl WREG10. Ihif Watch & M N B r i T -

K| 4-3: WATCH & O
Mwach =10/ ]
AddSFH”W’HEG‘ID VI AddSymboIllarrayB VI
Address | Symwbhol Name | Value I
0s00 arrayl
1800 arrayi
ogz0o array’d
a0zz ACCH Ox00000o00a0
aoio WEEGS Oxooo0o
0014 WEEG10 0x0000
(s
[wiatch1 Watch2| Watch3| Watchd]

R ART 5  ZETL I S AT T B . REFF I8 AT BTN ki

arrayl fll array2 Wi%

EAWE THIMHE, 8 array3 NidjE4 0, BAEEA M modulo () 7.
MR IR TR Y, Az 2R NUR R B AN R AR L

It

>

*E:

AR AT TR0 3R KSR ECR A2 A v By L3R K B R
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&l 4-4: e BB T

IEN— o]
Add SFHl IWHEG‘I 1] VI Add Symboll IarrayS VI
Address | Symwbhol Name | Value I =
0s00 E arrayl
000 00 e [o]
o502z [1]
0504 [2]
aso6 [3]
as0s [4]
0504 [5]
asac [6]
O50E [7]
as10 [8]
g1z 0 e [2]
1800 B arrayz
1800 0 e [o]
1502 [1]
1504 [2]
1806 [3]
1808 [4]
1504 [5]
180cC [6]
180E [7]
1810 [8]
1812 e [9]
ogz0o B array3 e
e
0524 a
0528 a
asz2c a
0530 a
0534 a
[uT =10 = E N rel 0 hd
[wiatch1 | Watch2| Watch3| Watchd]
£ modulo. s LA 1) DO AR AL BB — AT .
Y
A 4-5: T2 XA SO B T A
Il C:'pic30_tools'examples',DSP_ASM\modulo.s - | Ellll
_
43 POP wio j
Ex] POP s
45
46 RETURH
47 ; Beturn to main C program
45
49 array loop:
50 ; Set up DO loop with count 'PRODLEN - 1' (passed in W3)
51 (B bo W3,  here
52
53 ; Do a point-hy-point multiply
54 MPY W4FWT, A, [WE]+=2, W4, [WiO]+=2, W7
55
=1 ; Store result in & 32-bit array pointed hy W2
57 MOV ACCAL, W5
55 MOV W5, [WZ++]
59
&0 MOV ACCAH, W5
61 here: MOV W5, [WZ++]
e o
4 3

SEAT B 54 IS Watch 5 1255 array3. SRR 0. %k RUN, iE7
—¥ DO 5. BIfE, array3 {1 EFH05 BT BoR O AR K H BN T 20
GETE
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&l 4-6: ARRAY3 {145 R—5 —XIE3F
Add SFHlIWHEG‘ID VI Add Symboll anay3 -
Address | Symwbhol Name | Value I -
ogz0o B array3
0524 e [1] 1z
0528 e [2] 27
asz2c e [3] 45
0530 e [ 2] 75
0534 e [5] 108
0538 e [6] 147
a53C e [T] 192
0540 243
0544 300
a0zz Ox00000o00a0
oo1o |
0014 WEEG10 =
[wiatch1 Watch2| Watch3| Watchd]
%K RUN, &F S Usts DO R G 45 R
A 4-7: ARRAY3 {45 R—5 — RFEH
Add SFHlIWHEG‘ID VI Add Symboll EIED -
Address | Symwbhol Name | Value I -
ogz0o B array3
0524
0528
asz2c
0530
0534
0538
a53C
0540
0544
a0zz
oo1o |
0014 WEEG10 0x1802 -
[wiatch1 Watch2| Watch3| Watchd]

BBk modulo. s HIWT miJf4% RUN frF F—IRTEA IS R . 23 JLIK RUN, BEH
ATV SGE I A . B, FEBR example3.c FHWI AL,
MRS AT A IEAE W AR, AT LB Watch & ORI E s o SRR 28 A TR P
I o] DU H e, BRIt AT il S DA AS: 2 A ik 1) HoAs T BT & BRI 0 #fr . 75
modulo () BRECHHGIHIEA A print £ () &R), R HEA e 7P
Wy CHARZRR i i rARas )

1 4-3: PRINTF () M#EBEF

modulo( arrayl, array2, array3, PRODLEN-1 );
printf ("Product Array\n") ;

for (array_index=0; array index<PRODLEN/2; array_ index++)
printf ("%$1d\n",array3 [array_index]) ;
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printf () EREUE ALK dsPIC 28 4F T UARTA R B K 1 B 5 N —A 30, 8i0e 'S
N & 0. %E$ Debugger > Settings i A\ Simulator Settings (BifZsi% &) %I ik
HE. i UART1 10 &30, %+ “Enable UARTI/O” , 4R 5 $% AR SOA N 2

Mprintf () FAUAIESHHE HH. Hdi OK.

& 4-8:

I [V Enable Uart] 10
Olutput

I * windaw
" File

UART110 — printf() &&

Oszc / Trace I
Uatl 10|

Break Options
[ebugger Animation

SCL Options |
Lirnitations

[ebug Options

Input File: I
¥ Rewind Input

Browse.... |

Browse.... |

o1

Cancel | Apply |

PIAE BB 4 E 0 H - (Project > Build All) , % Run, ib&iaf7T )L, 4R)5+% Halt.
B E OB L, aEIT View > Output K0 . s SIM UARTA &£, Hii
4 array3 BN FICK.

Kl 4-9:

printf () ¥l

Buid | Version Contral | Findin Files | MPLAE SIM ~ SIM Uart |

=10l x|

blih

7500

FProduct Array
108

432

97z

1728

2700

3888

h292

G912

4748

10800
FProduct Array
147

Lag

1323

|

© 2005 Microchip Technology Inc.
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45 TN

ARBESTE— TR ROIRET . f7 St — 2 N A

o WU AR ) DSP $5-4 K Ak HUX LU B AL b (1 57

« i printf () B AT LB N B EEE R P I BUE SR o 1 H X LE U
HESAEIN

o BB AEARRSE AL, IXFENT LA modulo. s FEESIETE AT E (i,
4-1 TP R IR AT R AR B AR, AR B 2 o QU R S S 4 D
XMODSRT = (unsigned int)arrayl;
XMODEND = (unsigned int)arrayl + PRODLEN - 1;

YMODSRT = (unsigned int)array2;

(

)
)
)
YMODEND = (unsigned int)array2 + PRODLEN - 1;

4.6 A )FuTEA

AL B RN B P 3K AE MPLAB IDE 85 i Hl MPLAB C30 i as. %
MPLAB IDE 1 MPLAB C30 Zii¥#s I thfeix Bk e 3], ERAHELZMER, 1HS%H
et MPLAB IDE 7E2:#51.  (MPLAB C30 Z71% 434 /' #%%) 1 MPLAB ASM30.
MPLAB LINK30 and Utilities User's Guide, MM JT UG48 i 26 T Bl T & N .

i3t MPLAB IDE 754k # B 5% 5% www.microchip.com [ 5 1 56 7> MPLAB C 7 i
W28 Tn el o] USERISRAS Bl e E AR REX, RIF AL TR, FRRS
W T AT —ANE 1] MPLAB C30 i i 2% 1:HE X .

13t 7E Microchip W3 b3 AR 38 40 % IR Ss,  H P al LM 34556 T MPLAB C30
PR AR R A . AETT R T H hik$e MPLAB C 2% 282, ik i) LAAE B i As & A I
BREGES, 3R T MPLAB C30 4 i as s B .
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A

424 MPLAB ASM30. MPLAB LINK30 Fli& = T A5z H
T ettt 7
7225 MPLAB ASM30 1 MPLAB LINK30 ....ovvee.... 7
ZZ3E MPLAB C30 ..ottt 7
B

B TE Y oo 32
I T e 18
ZRPEII ] oot 18
GRTEIETI oo enn e 14
C

BEFETM oottt 8,50
Y el N SR 25
RS o = USRS 10
BIBEITE oot 10
D

BT E ettt 20, 21, 46
F

JEIEIRTET D e 24
H

WA C X SIEGR T oo 43

J

B, T ettt 40
A et 38
K

R T R et 5
L

TR IR 1ottt 23
M

MiICrochip PAEE ..oveieeececee e 1,4
MPLAB SIM AR oo 20, 37, 46
TRV OSSR 27
(o]

OULPUL T 1T 1o 18

P
PHANEE() e 45
PR BT e 49
L ettt 37
S
I BT B VT ettt ettt 33
BHZL e et 46
T
TRIISCAE BT oo 11
T T IG5 et 4
FELFIT oottt 3
U
UARTT 1O ettt ettt een e 49
w
WELCH T8 0 ettt 21,22, 46
WWW BB .t 4
R
I ettt 1
BB e e 2
X
SEIZE MPLAB C30 ..ottt 7
I oottt 10
B [ RSP 13,45
THE TG oottt ettt 10, 45
Y
BRUEE I HEIEE .ottt 4
B T ST ettt ettt 23
T T B oo ettt 10
V4
PRTGRITEL , I <o 37
T IR 5 5 T et 34
BT T ettt 41
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2355 West Chandler Blvd.
Chandler, AZ 85224-6199
Tel: 1-480-792-7200

Fax: 1-480-792-7277
FORSFF
http://support.microchip.com
k3k: www.microchip.com

WHF2£ K Atlanta
Alpharetta, GA

Tel: 1-770-640-0034
Fax: 1-770-640-0307

P14 Boston
Westborough, MA
Tel: 1-774-760-0087
Fax: 1-774-760-0088

ZnE Chicago
Itasca, IL

Tel: 1-630-285-0071
Fax: 1-630-285-0075

L8 Dallas
Addison, TX

Tel: 1-972-818-7423
Fax: 1-972-818-2924

JE45 4t Detroit
Farmington Hills, MI

Tel: 1-248-538-2250
Fax: 1-248-538-2260
Fl3L % Kokomo
Kokomo, IN

Tel: 1-765-864-8360
Fax: 1-765-864-8387

¥ 12W1 Los Angeles
Mission Viejo, CA

Tel: 1-949-462-9523
Fax: 1-949-462-9608
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Tel: 1-650-215-1444
Fax: 1-650-961-0286
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Canada

Tel: 1-905-673-0699
Fax: 1-905-673-6509

TAHX
FHE - R

Tel: 86-10-8528-2100
Fax: 86-10-8528-2104

FE - R

Tel: 86-28-8676-6200
Fax: 86-28-8676-6599
FE - EM

Tel: 86-591-8750-3506
Fax: 86-591-8750-3521
T - FEAEHTBIX
Tel: 852-2401-1200
Fax: 852-2401-3431

FHE- L
Tel: 86-21-5407-5533
Fax: 86-21-5407-5066

T HE - s
Tel: 86-24-2334-2829
Fax: 86-24-2334-2393

-
Tel: 86-755-8203-2660
Fax: 86-755-8203-1760

2z

i ig:
Tel: 86-757-2839-5507
Fax: 86-757-2839-5571

FE-FY
Tel: 86-532-8502-7355
Fax: 86-532-8502-7205

HE -

Tel: 86-27-5980-5300
Fax: 86-27-5980-5118
GHIX - ik

Tel: 886-7-536-4818
Fax: 886-7-536-4803
HEHKX - Gt

Tel: 886-2-2500-6610
Fax: 886-2-2508-0102
GHIX - FT

Tel: 886-3-572-9526
Fax: 886-3-572-6459

WA HX
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Tel: 61-2-9868-6733
Fax: 61-2-9868-6755
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Tel: 91-80-2229-0061

Fax: 91-80-2229-0062
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Tel: 91-11-5160-8631
Fax: 91-11-5160-8632

HZ Japan - Kanagawa
Tel: 81-45-471- 6166

Fax: 81-45-471-6122

#H Korea - Seoul
Tel: 82-2-554-7200

Fax: 82-2-558-5932 &Y
82-2-558-5934

IkyPE W Malaysia - Penang
Tel:011-604-646-8870
Fax:011-604-646-5086

3E4t# Philippines - Manila
Tel: 011-632-634-9065

Fax: 011-632-634-9069
Finyk Singapore

Tel: 65-6334-8870

Fax: 65-6334-8850

KR

BHF| Austria - Weis
Tel: 43-7242-2244-399
Fax: 43-7242-2244-393

7% Denmark - Ballerup
Tel: 45-4450-2828

Fax: 45-4485-2829

% H France - Massy

Tel: 33-1-69-53-63-20

Fax: 33-1-69-30-90-79
#£E Germany - Ismaning
Tel: 49-89-627-144-0

Fax: 49-89-627-144-44

A XF Italy - Milan

Tel: 39-0331-742611

Fax: 39-0331-466781
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